pom.xml
<?xml version="1.0" encoding="UTF-8"?> 
<project xmlns="http://maven.apache.org/POM/4.0.0" 
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> 
    <modelVersion>4.0.0</modelVersion> 
 
    <groupId>rgeo</groupId> 
    <artifactId>practice</artifactId> 
    <version>1.0-SNAPSHOT</version> 
 
    <repositories> 
        <repository> 
            <id>maven2-repository.dev.java.net</id> 
            <name>Java.net repository</name> 
            <url>http://download.java.net/maven/2</url> 
            <snapshots> 
                <enabled>true</enabled> 
            </snapshots> 
            <layout>default</layout> 
        </repository> 
        <repository> 
            <id>osgeo</id> 
            <name>Open Source Geospatial Foundation Repository</name> 
            <url>http://download.osgeo.org/webdav/geotools/</url> 
        </repository> 
        <repository> 
            <snapshots> 
                <enabled>true</enabled> 
            </snapshots> 
            <id>boundless</id> 
            <name>Boundless Maven Repository</name> 
            <url>http://repo.boundlessgeo.com/main</url> 
        </repository> 
        <repository> 
            <id>geosolutions</id> 
            <name>GeoSolutions Repository</name> 
            <url>http://maven.geo-solutions.it</url> 
        </repository> 
    </repositories> 
 
    <properties> 
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> 
        <!-- I do not use the latest snapshot, I use the version also used by the latest GeoServer --> 
        <geotools.version>13-SNAPSHOT</geotools.version> 
        <jai.version>1.0.3</jai.version> 
    </properties> 
 
    <dependencies> 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>geotools</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-main</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-geotiff</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-shapefile</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-coverage</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-epsg-hsql</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>junit</groupId> 
            <artifactId>junit</artifactId> 
            <version>4.12</version> 
            <scope>test</scope> 
        </dependency> 
 
        <dependency> 
            <groupId>it.geosolutions.jaiext.algebra</groupId> 
            <artifactId>jt-algebra</artifactId> 
            <version>${jai.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-geojson</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools.xsd</groupId> 
            <artifactId>gt-xsd-kml</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>de.micromata.jak</groupId> 
            <artifactId>JavaAPIforKml</artifactId> 
            <version>2.2.0</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-api</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.hamcrest</groupId> 
            <artifactId>hamcrest-core</artifactId> 
            <version>1.3</version> 
        </dependency> 
 
        <dependency> 
            <groupId>org.geotools</groupId> 
            <artifactId>gt-grib</artifactId> 
            <version>${geotools.version}</version> 
        </dependency> 
    </dependencies> 
</project>